how to install mainline kernel 4.16.4 or 4.17-rc2 on Ubuntu 16.04

you cannot install fresh kernel on your long-standing Ubuntu system?

не можешь поставить свежее ядро в свою допотопную Убунточку?

Setting up linux-image-unsigned-4.16.4-041604-generic (4.16.4-041604.201804240433) …

/var/lib/dpkg/info/linux-image-unsigned-4.16.4-041604-generic.postinst: 50: /var/lib/dpkg/info/linux-image-unsigned-4.16.4-041604-generic.postinst: linux-update-symlinks: not found

dpkg: error processing package linux-image-unsigned-4.16.4-041604-generic (--install):

subprocess installed post-installation script returned error exit status 127

but you also cannot remove it from now on?

Removing linux-image-unsigned-4.16.4-041604-generic (4.16.4-041604.201804240433) …

/var/lib/dpkg/info/linux-image-unsigned-4.16.4-041604-generic.prerm: 11: /var/lib/dpkg/info/linux-image-unsigned-4.16.4-041604-generic.prerm: linux-check-removal: not found

dpkg: error processing package linux-image-unsigned-4.16.4-041604-generic (--remove):

subprocess installed pre-removal script returned error exit status 127

pay attention to "not found": version 4.0ubuntu1 of package linux-base does not contain linux-update-symlinks and linux-check-removal scripts at least. so download and install version 4.5ubuntu1 — http://archive.ubuntu.com/ubuntu/pool/main/l/linux-base/linux-base_4.5ubuntu1_all.deb

Настраивается пакет linux-image-unsigned-4.16.4-041604-generic (4.16.4-041604.201804240433) …

/var/lib/dpkg/info/linux-image-unsigned-4.16.4-041604-generic.postinst: 50: /var/lib/dpkg/info/linux-image-unsigned-4.16.4-041604-generic.postinst: linux-update-symlinks: not found

dpkg: ошибка при обработке пакета linux-image-unsigned-4.16.4-041604-generic (--install):

подпроцесс установлен сценарий post-installation возвратил код ошибки 127

но и удалить его тоже уже не получается?

Удаляется linux-image-unsigned-4.16.4-041604-generic (4.16.4-041604.201804240433) …

/var/lib/dpkg/info/linux-image-unsigned-4.16.4-041604-generic.prerm: 11: /var/lib/dpkg/info/linux-image-unsigned-4.16.4-041604-generic.prerm: linux-check-removal: not found

dpkg: ошибка при обработке пакета linux-image-unsigned-4.16.4-041604-generic (--remove):

подпроцесс установлен сценарий pre-removal возвратил код ошибки 127

обрати внимание на «not found»: в установленной у тебя версии 4.0ubuntu1 пакета linux-base не хватает скриптов linux-update-symlinks и linux-check-removal как минимум. поэтому скачай и накати версию 4.5ubuntu1 — http://archive.ubuntu.com/ubuntu/pool/main/l/linux-base/linux-base_4.5ubuntu1_all.deb

Сёма Мрачный
tags: tipz , Ubuntu

good luck!

see you soon…

buena suerte!

hasta pronto…

удачи!

до скорого…

sorry, currently no translation is available.

feel free to make translation by yourself and even send it via pull requests.

lo siento, actualmente traducción no está disponible.

no dude en hacer la traducción por ti mismo e incluso enviarlo por pull requests.

сожалею, перевода пока нет.

не стесняйся сделать перевод самостоятельно и даже прислать его через pull requests.